Настройка MikroTik CRS

. Просмотров: 1451

Рейтинг:  5 / 5

Звезда активнаЗвезда активнаЗвезда активнаЗвезда активнаЗвезда активна
 

Ранее я показал как настроить MikroTik CRS125-24G-1S-RM, но то решение будет работать только на ROS до v6.41. Начиная с v6.41  инженеры MikroTik немного упростили взаимодействие с чипом коммутаци. 

CRS125-24G-1-RM

Задача остается такой же, как и в предыдущем примере: у насть есть три VLAN:

VLAN10 - нетегировыный на портах ether1-ether10
VLAN20 - нетегировыный на портах ether11-ether20
VLAN30 - нетегировыный на портах ether21-ether22. Используется для управления устройством.

На портах ether23-24 и sfp1 весь трафик тегированый (в описании cisco как trunk, но у MikroTik в слово trunk вкладывается другое понятие)).
ether24 теперь не используется как мастер-порт. Вообще, больше нет такого понятия как мастер-порт. 

 

Все настройки производим на чистом оборудовании без преминения настроек по умолчанию. Версия ROS 6.41.1
Настраивать лучше через консоль, ну или 24 порт. 

1. Создаем бридж и помещаем в него все итрефейсы.
/interface bridge add name=bridge1 igmp-snooping=no protocol-mode=none

/interface bridge port
add bridge=bridge1 interface=ether1 hw=yes
add bridge=bridge1 interface=ether2 hw=yes
add bridge=bridge1 interface=ether3 hw=yes
add bridge=bridge1 interface=ether4 hw=yes
add bridge=bridge1 interface=ether5 hw=yes
add bridge=bridge1 interface=ether6 hw=yes
add bridge=bridge1 interface=ether7 hw=yes
add bridge=bridge1 interface=ether8 hw=yes
add bridge=bridge1 interface=ether9 hw=yes
add bridge=bridge1 interface=ether10 hw=yes
add bridge=bridge1 interface=ether11 hw=yes
add bridge=bridge1 interface=ether12 hw=yes
add bridge=bridge1 interface=ether13 hw=yes
add bridge=bridge1 interface=ether14 hw=yes
add bridge=bridge1 interface=ether15 hw=yes
add bridge=bridge1 interface=ether16 hw=yes
add bridge=bridge1 interface=ether17 hw=yes
add bridge=bridge1 interface=ether18 hw=yes
add bridge=bridge1 interface=ether19 hw=yes
add bridge=bridge1 interface=ether20 hw=yes
add bridge=bridge1 interface=ether21 hw=yes
add bridge=bridge1 interface=ether22 hw=yes
add bridge=bridge1 interface=ether23 hw=yes
add bridge=bridge1 interface=ether24 hw=yes
add bridge=bridge1 interface=sfp1 hw=yes

2. Назначаем весь входящий страфик с интерфейсов в определеный vlan.
/interface ethernet switch ingress-vlan-translation
add new-customer-vid=10 sa-learning=yes ports=ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10
add new-customer-vid=20 sa-learning=yes ports=ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20
add new-customer-vid=30 sa-learning=yes ports=ether21,ether22

3. Указываем порты на которых vlan будет тегированым (у cisco это trunk порт, у mikrotik в слово trunк вложен в другой смысл)
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether23,ether24,sfp1 vlan-id=10
add tagged-ports=ether23,ether24,sfp1 vlan-id=20
add tagged-ports=ether23,ether24,sfp1,switch1-cpu vlan-id=30

4. Указываем на каких портах какой vlan может ходить
/interface ethernet switch vlan
add ports=ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether23,ether24,sfp1 vlan-id=10 learn=yes
add ports=ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20,ether23,ether24,sfp1 vlan-id=20 learn=yes
add ports=ether21,ether22,ether23,ether24,sfp1,switch1-cpu vlan-id=30 learn=yes

5. Делаем порт управления коммутатором (порт который будет видется в winbox поиске, на него же вешается ip адрес, если надо)
/interface vlan add name=vlan30 interface=bridge1 vlan-id=30

6. В конце ставим защиту на портах - весь трафик с непонятных vlan блокируем.
Будьте осторонжны, проверьте все настройки, а то можете потерять доступ к коммутатору, и придется сбрасывать настройки
/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports=ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20,ether21,ether22,ether23,ether24,sfp1

Более подробно можно почитать на сайте производителя https://wiki.mikrotik.com/wiki/Manual:CRS_examples

 

Недостаточно прав для комментирования

Tags: ROS6