Настройка коммутатора MikroTik CRS125-24G-1S-RM

. Просмотров: 1556

Рейтинг:  5 / 5

Звезда активнаЗвезда активнаЗвезда активнаЗвезда активнаЗвезда активна
 

В данном примере показана настройка коммутатора MikroTik CRS125-24G-1S-RM с использованием чипа коммутации на примере двух VLAN и одним VLAN для управления, и сравнение с аналогичной настройкой Cisco, Eltex, D-Link.

Использование возможностей чипа коммутации дает существенное, в десятки раз, увеличение пропускной способности на L2.

CRS125-24G-1-RM

И так, у насть есть три VLAN:

VLAN10 - нетегировыный на портах ether1-ether10

VLAN20 - нетегировыный на портах ether11-ether20

VLAN30 - нетегировыный на портах ether21-ether22. Используется для управления устройством и имеет ip адрес.

Порты ether23-24 & sfp1 транковые. ether24 используется как мастер-порт.

 

Все настройки производим на чистом оборудовании без преминения настроек по умолчанию. Версия ROS 6.40.

MikroTik CRS125-24G-1S-RM:

/interface ethernet
set ether24 comment=master

/interface vlan
add interface=ether24 name=ether24-vlan10 vlan-id=10
add interface=ether24 name=ether24-vlan20 vlan-id=20
add interface=ether24 name=ether24-vlan30 vlan-id=30

/interface ethernet
set ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20,ether21,ether22,ether22,sfp1 master-port=ether24

/interface ethernet switch egress-vlan-tag
add tagged-ports=ether23,ether24,sfp1 vlan-id=10
add tagged-ports=ether23,ether24,sfp1 vlan-id=20
add tagged-ports=ether23,ether24,sfp1,switch1-cpu vlan-id=30

/interface ethernet switch egress-vlan-translation
add customer-vid=10 customer-vlan-format=untagged-or-tagged new-customer-vid=0 ports=ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10 service-vlan-format=untagged-or-tagged
add customer-vid=20 customer-vlan-format=untagged-or-tagged new-customer-vid=0 ports=ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20 service-vlan-format=untagged-or-tagged
add customer-vid=30 customer-vlan-format=untagged-or-tagged new-customer-vid=0 ports=ether21,ether22 service-vlan-format=untagged-or-tagged

/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=10 ports=ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10
add customer-vid=0 new-customer-vid=20 ports=ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20
add customer-vid=0 new-customer-vid=30 ports=ether21,ether22

/interface ethernet switch vlan
add ports=ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether23,ether24,sfp1 vlan-id=10
add ports=ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20,ether23,ether24,sfp1 vlan-id=20
add ports=ether21,ether22,ether23,ether24,sfp1,switch1-cpu vlan-id=30

/ip address add address=192.168.30.1/24 interface=ether24-vlan30

/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports="ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20,ether21,ether22,ether23,ether24,sfp1"

Хочу обратить внимание, на VLAN управления: у него должен быть добавлен switch1-cpu. Если на других VLAN вам также необходимо присвоить ip адрес, то также необходимо добавить switch1-cpu.

Подробно описывать что и как не буду. Все есть на сайте производителя  Port_Based_VLAN.


Для сравнения предлагаю пример аналогичной настройки на коммутаторах других производителей:

Cisco Catalyst WS-C2960-24TT-L
Cicso, он и в африке Cisco
vlan 10,20,30

interface range fa0/1-10
switchport access vlan 10
exit


interface range fa0/11-20
switchport access vlan 20
exit


interface range fa0/21-22
switchport access vlan 30
exit

interface range fa0/23-24
switchport trunk allowed vlan 10,20,30
switchport mode trunk
exit

interface Vlan30
ip address 192.168.30.4 255.255.255.0
no shutdown
exit
exit

 


Eltex MES1124M
Хороший отечественный коммутатор. Особенно порадовало наличие защиты до 10кВ на каждом порту. CLI похож на Cisco. Рекомендую!
vlan database
vlan 10,20,30

interface range fa1/0/1-10
switchport access vlan 10

interface range fa1/0/11-20
switchport access vlan 20

interface range fa1/0/21-22
switchport access vlan 30

interface range fa/0/23-24
switchport mode trunk
switchport trunk allowed vlan add 10,20,30

interface vlan 30
ip address 192.168.30.2 /24
exit
exit

Обратите внимание на схожесть комманд с Cisco :)


D-Link DGS-1210-28/ME

Коммутатор, как коммутатор, со всеми "болячками" данного производителя. По мне так, ничем не выделяется. Один плюс - широко распространенный среди провайдеров, соответственно быстро можно найти замену сгоревшему.
config vlan default delete 1-24
create vlan 10 tag 10
create vlan 20 tag 20
create vlan 30 tag 30

config vlan 10 add untagged 1-10
config vlan 10 add tagged 23-24 

config vlan 20 add untagged 11-20
config vlan 20 add tagged 23-24 

config vlan 30 add untagged 21-22
config vlan 30 add tagged 23-24 

config ipif System ipaddress 192.168.30.3/24 vlan 30 state enable

Как видите, простотой настройку коммутации на Mikrotik ROS, по сравнению с другими производителями, не назовешь. Тем лучше для специалистов - всегда будут нужны :)

 

Недостаточно прав для комментирования

Tags: ROS6