MikroTik на виртуальном сервере с прямым ip-адресом за 97р

. Просмотров: 5362

Рейтинг:  5 / 5

Звезда активнаЗвезда активнаЗвезда активнаЗвезда активнаЗвезда активна
 

Предлагаю интересное решение по размещению MikroTik на вирутальном сервере с прямым ip-адресом всего за 97р в месяц (а тем кто успеет заказать до 05.01.2017 за 46р). За основу взят доклад Димтрия Пичулина на MUM, Дмитрий и предложил вариант дешевого VPS.

Варианты применения: VPN сервер, Hotspot сервер, Прокси сервер, внешний Dude сервер и т.д.
К примеру, у меня дома Ростелеком хочет 200р в месяц за статический прямой адрес. Звери! Так я лучше людям за целый VPS заплачу в разы меньше и получу прямой адрес и в добавок еще машину для экспериментов. А если взять VPS у буржуев, тот же Digitalocean, будет дороже, но возможностей больше.

И так, приступим:

  1. Регистрируемся на виртуальном хостинге
  2. Авторизуемся и заходим Товары/Услуги -> Виртуальные серверы и нажимаем Заказать.
  3. Выбираем "Виртуальный сервер для разработчиков Cloud VPS # 256Mb | 3GB SSD | 1 vCore"
    Выбираем VPS на cloud4box
  4. Если до 5.01.2017, то вводим промо код NY2017 и получаем скидку 50% (хостинг лучше заказывать сразу на год, т.к. скидка на продление не действует)
    Новогодняя скидка cloud4box
  5. Сервер создается в течении нескольких часов. На почту придет подверждение.
  6. После создания сервера, подключаемся к нему по ssh.
  7. Скачиваем и устанавливаем образ MikroTik CHR.

    wget http://download2.mikrotik.com/routeros/6.36.4/chr-6.36.4.img.zip -O chr.img.zip
    echo u > /proc/sysrq-trigger && gunzip -c chr.img.zip | dd of=/dev/vda

  8. Через VMmanager перезагружаем виртуальную машину
  9. Спустя минуту, через тот же VMmanager подключаемся по VNC к машине.
  10. Если все сделали правильно, видим приглашение MikroTik.
    Приглашение MikroTik

  11. Входим под admin без пароля.
  12. Первым делом устанавливаем пароль для admin, т.к. скорее всего вас сразу же начнут атаковать подбором пароля.

    /user set admin password=Ваш Пароль

    mikrotik bruteforce пример
  13. Настраиваем сеть. Параметры подключения можно увидеть в настройках виртуальной машины в разделе "ip адреса".

    /ip address add interface=ether1 address=95.182.XX.XX/24
    /ip route add gateway=95.182.XX.1
  14. Далее подключаемся через Winbox и наслаждаемся.
    MikroTik на cloud4box

PS: лицензия на MikroTik: по умолчанию стоит free, которая имеет только ограничение в 1Мбит на канал. Других ограничений нет ! 
За 45$ можно повысить уровень лицензии до perpetual1 с ограничением в 1Гбит. 

 

Комментарии  

0 # Олег 04.01.2017 20:51
Доброго времени суток! Спасибо за статьи, много дач себя подчерпнул. Вопрос по лицензии микротика: если в следующем году я надумаю перенести сервер микротика на другой хостинг, я ведь лицензию микротика потеряю?
0 # papa-admin 04.01.2017 23:13
Цитирую Олег:
Вопрос по лицензии микротика: если в следующем году я надумаю перенести сервер микротика на другой хостинг, я ведь лицензию микротика потеряю?

Смотря как переносить будете. Если id диска не изменится, то не потеряете. Да, и да если потеряете, её вроде заменить можно.
А бесплатную лицензию всегда можете еще раз взять, если сменится id диска.
0 # Олег 04.01.2017 22:35
До 5 января включительно!
+1 # Антон 08.03.2017 21:06
Привет, спасибо за мануал!
А что со скоростью на этом тарифе? Читаю, никак не пойму, 1280 килобайт в секунду это 10 мегабит на входящий трафик?
0 # papa-admin 09.03.2017 08:31
Цитирую Антон:
Привет, спасибо за мануал!
А что со скоростью на этом тарифе? Читаю, никак не пойму, 1280 килобайт в секунду это 10 мегабит на входящий трафик?

Скорее всего это ограничение бесплатной лицензии.

Недостаточно прав для комментирования